Thank you

On 31-Mar-2017, at 12:09 AM, Harris, James R <> wrote:

On Mar 30, 2017, at 5:43 AM, Kiran Dikshit <> wrote:

Hi All,

I have 2 part question relating to performance benchmarking of the SPDK and fio_plugin. 

1. Is there any reference document specifying the workload types , queue depth and block size used for benchmarking the SPDK performance numbers. 
    Is there any OS level performance tuning to be done. It will be great if we can get some insight on the performance testbed used.

Note : 
     I did find the DPDK  performance optimisation guidelines Which is useful. 

Hi Kiran,

Most of the tests we run for driver performance comparisons are with 4KB random reads.  This puts the most stress on the driver, since on NAND SSDs, random read performance is typically much higher than random write performance.  For throughput tests, queue depth is typically tested at 128.  For latency tests, queue depth is typically tested at 1.

2.  I am trying fio_plugin for benchmarking the performance, the jobs are completing with following error 

nvme_pcie.c: 996:nvme_pcie_qpair_complete_pending_admin_request: ***ERROR*** the active process (pid 6700) is not found for this controller.

I found that the  nvme_pcie_qpair_complete_pending_admin_request()is checking if the process exist, this is where the error message is coming from.
I am not sure how this process is getting killed even before completion. There is no there operation done on this system apart from running fio plugin.
Was any similar issue seen in the past, which might be of help to get around this error.

Could you post the contents of your fio job file?  Note that the SPDK fio plugin is currently limited to a single job.  I would expect to see an error like this if specifying multiple jobs and without -thread (meaning a separate process per job).



Below is my setup details 

OS : fedora 25 ( server edition )
Kernel version : 4.8.6-300
DPDK version : 6.11

I have attached a single nvme drive of 745GB from Intel on which i am running the FIO 

Below workaround were tried and the issue still persists not sure how to get around this. 


1. Tried different workloads in FIO 
2. I did detach the NVMe and attach a new NVMe drive 
3. Re-installed the DPDK , SPDK and FIO tool

Note :
Following links were used to install and setup SPDK and FIO plugin

Thank you
SPDK mailing list

SPDK mailing list