I received the error "Multiple sessions detected" from iwctl after running "iwctl wsc wlan0 push-button". The same Wi-Fi card was working with WSC on the same Wi-Fi router when I tried it a week or so ago, and I have since reformatted the disk of the computer with the Wi-Fi client station. After looking at the source of wsc.c, I believe I have bumped into something the code doesn't anticipate correctly in the case of a mesh Wi-Fi installation.

I was trying to pair a Qualcomm Atheros QCA986x/988x with an Amplifi HD Wi-Fi router that has an Amplifi mesh extender. Both units are running with SSID "topcog" on 2.4 GHz and 5 GHz, and they each have an additional SSID, "topcog_5ghz". It looks like iwd gave the pairing a thumbs-down because it was getting the same offer from two different BSSIDs for SSID "topcog" in the 5 GHz band. When I unplugged the extender and tried the pairing again, it succeeded.

I've attached the relevant journal entries with debug turned on. If I can do additional testing, please let me know. I'm not doing dev work on iwd, but since I'm building my project using OpenEmbedded, it shouldn't be too hard for me to stick in some debug code.

The source shows that I'm building with release 1.6 (git hash ad97f4f9).

Thanks!
--
Bruce A. Johnson
Herndon, Virginia