Thanks everyone for the reply, Malcom’s suggestion did the trick.

 

Hi,

 

There are a small number of additional packages that need to be installed or upgraded along with e2fsprogs. These are kept in the same downloads directory as the Intel/WC e2fsprogs packages. The following steps are one way to update e2fsprogs:

 

cd $HOME

wget -r -np http://downloads.whamcloud.com/public/e2fsprogs/latest/el6/RPMS/x86_64/

cd $HOME/downloads.whamcloud.com/public/e2fsprogs/latest/el6/RPMS/x86_64/

sudo rpm -Uvh e2fsprogs-?.* e2fsprogs-libs-?.* lib*

 

Regards,

 

Malcolm.

 

Thanks,

-Upanshu

 

From: Anibal Moreno [mailto:anibal.moreno86@gmail.com]
Sent: Wednesday, July 24, 2013 3:10 PM
To: Singhal, Upanshu
Cc: Peng Tao; hpdd-discuss@lists.01.org
Subject: Re: [HPDD-discuss] Issue installing e2fsprogs on RHEL 6.3 for Lustre 2.3

 

Hi,

 

Try to unninstall de kernel firmware packge and install the kernel firmware from whamcloud repo.

I had the same error but with this instruction i solved it.

 

PD: I recomend deactivate yum repo from externally source to avoid dependence resolv and avoid problems. 

 

BR,

Anibal

 

2013/7/24 Singhal, Upanshu <upanshu.singhal@emc.com>

Hello Tao,

Thanks for your email. I already have libcom_err and libss. I even tried following command, but receive an error:

[root@lustre-5 lustre]# rpm -Uvh ./e2fsprogs-1.42.7.wc1-7.el6.x86_64.rpm ./e2fsprogs-libs-1.42.7.wc1-7.el6.x86_64.rpm ./libcom_err-1.42.7.wc1-7.el6.x86_64.rpm
error: Failed dependencies:
        libcom_err = 1.41.12-12.el6 is needed by (installed) libss-1.41.12-12.el6.x86_64
        libcom_err = 1.41.12-12.el6 is needed by (installed) libcom_err-devel-1.41.12-12.el6.x86_64


[root@lustre-5 lustre]# rpm -Uvh ./e2fsprogs-1.42.7.wc1-7.el6.x86_64.rpm ./e2fsprogs-libs-1.42.7.wc1-7.el6.x86_64.rpm ./libcom_err-1.42.7.wc1-7.el6.x86_64.rpm ./libss-1.42.7.wc1-7.el6.x86_64.rpm
error: Failed dependencies:
        libcom_err = 1.41.12-12.el6 is needed by (installed) libcom_err-devel-1.41.12-12.el6.x86_64

Thanks,
-Upanshu


-----Original Message-----
From: Peng Tao [mailto:bergwolf@gmail.com]
Sent: Wednesday, July 24, 2013 2:57 PM
To: Singhal, Upanshu
Cc: hpdd-discuss@lists.01.org
Subject: Re: [HPDD-discuss] Issue installing e2fsprogs on RHEL 6.3 for Lustre 2.3

On Wed, Jul 24, 2013 at 5:19 PM, Singhal, Upanshu <upanshu.singhal@emc.com> wrote:
> Hello,
>
>
>
> In order to install and configure Lustre 2.3 on RHEL 6.3, I am
> installing e2fsprogs packages. But I get following error, does anyone
> have faced the similar issue, if so, then what is the resolution?
>
>
>
> [root@lustre-5 lustre]# rpm -Uvh
> ./e2fsprogs-1.42.7.wc1-7.el6.x86_64.rpm
> ./e2fsprogs-libs-1.42.7.wc1-7.el6.x86_64.rpm
>
> error: Failed dependencies:
>
>        libcom_err >= 1.42.2 is needed by
> e2fsprogs-1.42.7.wc1-7.el6.x86_64
>
You can get the required libcom_err rpm from whamcloud's website:
http://downloads.whamcloud.com/public/e2fsprogs/1.42.7.wc1/el6/RPMS/x86_64/

Thanks,
Tao

>
>
> Thanks,
>
> -Upanshu
>
>
>
>
>
> Upanshu Singhal
>
> EMC Data Storage Systems, Bangalore, India.
>
> Phone: 91-80-67375604
>
>
>
>
> _______________________________________________
> HPDD-discuss mailing list
> HPDD-discuss@lists.01.org
> https://lists.01.org/mailman/listinfo/hpdd-discuss
>

_______________________________________________
HPDD-discuss mailing list
HPDD-discuss@lists.01.org
https://lists.01.org/mailman/listinfo/hpdd-discuss



 

--

Saludos,
AnÝbal