ISSUE: I receive the following errors when attempting to mount ZFS:

 

KERNEL: Linux mds01 3.10.0-514.el7_lustre.x86_64 #1 SMP Wed Dec 7 15:50:02 PST 2016 x86_64 x86_64 x86_64 GNU/Linux

 

ERROR 1:

[root@mds01 ~]# mount -t lustre mds01-pool/mdsZFS /mnt/lustre/

mount.lustre: mount mds01-pool/mdsZFS at /mnt/lustre failed: No such device

Are the lustre modules loaded?

Check /etc/modprobe.conf and /proc/filesystems

 

ERROR 2 (in /var/log/messages):

Dec 23 09:18:58 mds01 kernel: LustreError: 158-c: Can't load module 'osd-zfs'

Dec 23 09:18:58 mds01 kernel: LustreError: 56472:0:(genops.c:314:class_newdev()) OBD: unknown type: osd-zfs

Dec 23 09:18:58 mds01 kernel: LustreError: 56472:0:(obd_config.c:366:class_attach()) Cannot create device mdsZFS-MDT0000-osd of type osd-zfs : -19

Dec 23 09:18:58 mds01 kernel: LustreError: 56472:0:(obd_mount.c:194:lustre_start_simple()) mdsZFS-MDT0000-osd attach error -19

Dec 23 09:18:58 mds01 kernel: LustreError: 56472:0:(obd_mount_server.c:1810:server_fill_super()) Unable to start osd on mds01-pool/mdsZFS: -19

Dec 23 09:18:58 mds01 kernel: LustreError: 56472:0:(obd_mount.c:1449:lustre_fill_super()) Unable to mount  (-19)

 

MODULES INSTALLED:

kernel-headers-3.10.0-514.el7_lustre.x86_64

kmod-lustre-osd-ldiskfs-2.9.0-1.el7.x86_64

lustre-osd-zfs-mount-2.9.0-1.el7.x86_64

kmod-lustre-tests-2.9.0-1.el7.x86_64

lustre-osd-ldiskfs-mount-2.9.0-1.el7.x86_64

kmod-lustre-osd-zfs-2.9.0-1.el7.x86_64

kernel-devel-3.10.0-514.el7_lustre.x86_64

kmod-lustre-2.9.0-1.el7.x86_64

lustre-iokit-2.9.0-1.el7.x86_64

lustre-2.9.0-1.el7.x86_64

kernel-3.10.0-514.el7_lustre.x86_64

e2fsprogs-libs-1.42.13.wc5-7.el7.x86_64

e2fsprogs-1.42.13.wc5-7.el7.x86_64

zfs-release-1-3.el7.centos.noarch

zfs-0.6.5.8-1.el7.centos.x86_64

libzfs2-0.6.5.8-1.el7.centos.x86_64

libzfs2-devel-0.6.5.8-1.el7.centos.x86_64

zfs-dkms-0.6.5.8-1.el7.centos.noarch

 

NOTE: In  order to get the ‘kmod-lustre-osd-zfs-2.9.0-1.el7.x86_64’ module installed, I had to use ‘rpm -ihv kmod-lustre-osd-zfs-2.9.0-1.el7.x86_64 –nodeps’. Without –nodeps, I would receive dependency warnings about missing nearly two pages references to KSYM.

 

Any ideas on how to overcome this issue?

 

 

Jeff Slapp | Director, Systems Engineering and Solution Architecture

DataCore Software Corporation
Corporate Park
6300 NW 5th Way
Ft. Lauderdale, FL 33309

http://www.datacore.com

THE DATA INFRASTRUCTURE SOFTWARE COMPANY