On Wednesday 24 July 2013 09:19:02 Singhal, Upanshu wrote:
In order to install and configure Lustre 2.3 on RHEL 6.3, I am installing
e2fsprogs packages. But I get following error, does anyone have faced the
similar issue, if so, then what is the resolution?
[root@lustre-5 lustre]# rpm -Uvh ./e2fsprogs-1.42.7.wc1-7.el6.x86_64.rpm
./e2fsprogs-libs-1.42.7.wc1-7.el6.x86_64.rpm error: Failed dependencies:
libcom_err >= 1.42.2 is needed by e2fsprogs-1.42.7.wc1-7.el6.x86_64
EMC Data Storage Systems, Bangalore, India.
I strongly suggest you to not go for Lustre 2.3 if you are working on a
production system. 2.1 and 2.4 are intended for production. (Imho 2.1 is still
an option since 2.4 is very new... but for new systems 2.4 is probably the bst
choice. Note that you must use RHEL 6.4 for lustre 2.4).
From the download website
you must download all needed deps. As you can see libcom_err 1.42.7 is there
as well. Download all the RPM you need and use yum localinstall <rpm file list>
to install all of them at once to have deps satisfied.