Not that sophisticated unfortunately.  If you have a stripe size of 4, even if you write a 1 byte file it creates 4 objects on 4 different OSTs at 1 MB each.

No matter the file size, the stripe count stays the same.  The initial stripe count is based on 1st if youíve set the stripe count specifically for that file, 2nd the stripe count on the directory, 3rd the stripe count on the file system

Shawn

On Feb 20, 2014, at 8:45 AM, E.S. Rosenberg <esr+hpdd-discuss@mail.hebrew.edu> wrote:




On Thu, Feb 20, 2014 at 4:42 PM, Hall, Shawn <Shawn.Hall@bp.com> wrote:
lfs setstripe needs to be run before the file is written since striping layout is determined at file creation time.  
I assume it is determined based on initial requested filesize? So if a program requests a file smaller then stripe size and then ramps up filesize it will never stripe, correct?
What youíll want to do is lfs setstripe -c <stripe_count> <iozone_output_directory> before you run iozone.  Then when you run iozone, make sure to write to a new file, as a file that already existed will have the former striping layout.  You can use lfs getstripe to verify.

Shawn

On Feb 20, 2014, at 8:32 AM, E.S. Rosenberg <esr+hpdd-discuss@mail.hebrew.edu> wrote:

re:all


On Thu, Feb 20, 2014 at 4:15 PM, Patrick Farrell <paf@cray.com> wrote:
Eli,

Your comment about dd means that at least some part of your file system is set up to stripe across multiple OSTs, but my first guess on hearing this would be that IOZone is working in a space where the default striping is left at 1.  Itís the simplest explanation, though that doesnít mean itís right. :)
Both dd and iozone are writing into the same directory, my current assumption is that since iozone constantly overwrites the same file that it initially created and wrote to in small chunks of data that striping never steps in...
I assume I can finetune that behavior away....

The lfs operation is run before running a command that will output to a file a a sort of 'touch' which tells lustre to write a file in a specific way?
Thanks,
Eli  

- Patrick

From: "E.S. Rosenberg" <esr+hpdd-discuss@mail.hebrew.edu>
Date: Thursday, February 20, 2014 at 8:01 AM
To: "hpdd-discuss@lists.01.org" <hpdd-discuss@lists.01.org>
Subject: [HPDD-discuss] iozone and lustre

Hi all,
When I run the iozone benchmark on lustre it ends up only using one OSS server, I assume this has something to do with the way it writes but I'm not really sure where to look, at the moment I am just using automated tests...

(iozone -Ra -g 64G)

lustre is functioning fine and when using dd from multiple machines with a bs=102400 it uses all OSS.

Any pointers would be very welcome...
Thanks,
Eli

_______________________________________________
HPDD-discuss mailing list
HPDD-discuss@lists.01.org
https://lists.01.org/mailman/listinfo/hpdd-discuss