Another possible suggestion - If you have not done so, a writeconf operation on all your targets is sometimes a necessary step in upgrading.

Instructions in the manual here:
http://build.whamcloud.com/job/lustre-manual/lastSuccessfulBuild/artifact/lustre_manual.xhtml#dbdoclet.50438199_54623

Write conf erases the configuration logs (which is where you're getting errors), causing them to be regenerated on next server start.  It should be safe to do repeatedly.  You will lose any tuning settings you've stored in the configuration logs.
(You may also need to do a write conf operation if you decide to roll back to 2.1 before 2.1 can mount those targets)


Also, if you use quotas, there are also quota format changes in Lustre 2.4 and newer that you may need to make (Others can correct me if this isn't necessary coming from 2.1.5, but I think it is)...

The manual is very dense in this area... I'd suggest reading this bit first:
http://build.whamcloud.com/job/lustre-manual/lastSuccessfulBuild/artifact/lustre_manual.xhtml#quota_interoperability

And then go back and read the full quota management/administration section:
http://build.whamcloud.com/job/lustre-manual/lastSuccessfulBuild/artifact/lustre_manual.xhtml#configuringquotas


On 05/28/2014 10:18 AM, Anthony Alba wrote:

We went via 2.4.2 to 2.5.1 which worked. Possibly 2.1 to 2.5 might be too great a version leap.

On 28 May 2014 23:12, "Roger Spellman" <Roger.Spellman@terascala.com> wrote:

Hi,


I formatted a file system with Lustre 2.1.5, and have used it for a while.  I just upgraded to Lustre 2.5.0.  I thought that I should be able to mount all the targets.  I was able to mount the MDT without a problem.  When I try to mount an OST, I get this error:

 

LDISKFS-fs (dm-6): mounted filesystem with ordered data mode. quota=off. Opts:

Lustre: srv-hss55-OST0002: No data found on store. Initialize space

LustreError: 48809:0:(obd_config.c:1341:class_process_proc_param()) hss55-OST0002: unknown param read_cache_enable=0

LustreError: 48809:0:(obd_config.c:1591:class_config_llog_handler()) MGC10.2.99.21@o2ib: cfg command failed: rc = -38

Lustre:    cmd=cf00f 0:hss55-OST0002  1:ost.read_cache_enable=0 

LustreError: 15c-8: MGC10.2.99.21@o2ib: The configuration from log 'hss55-OST0002' failed (-38). This may be the result of communication errors between this node and the MGS, a bad configuration, or other errors. See the syslog for more information.

LustreError: 48614:0:(obd_mount_server.c:1257:server_start_targets()) failed to start server hss55-OST0002: -38

LustreError: 48614:0:(obd_mount_server.c:1732:server_fill_super()) Unable to start targets: -38

LustreError: 48614:0:(obd_mount_server.c:848:lustre_disconnect_lwp()) hss55-MDT0000-lwp-OST0002: Can't end config log hss55-client.

LustreError: 48614:0:(obd_mount_server.c:1426:server_put_super()) hss55-OST0002: failed to disconnect lwp. (rc=-2)

Lustre: Failing over hss55-OST0002

Lustre: server umount hss55-OST0002 complete

LustreError: 48614:0:(obd_mount.c:1311:lustre_fill_super()) Unable to mount  (-38)

mount.lustre: mount /dev/mapper/map02 at /mnt/ost2 failed: Function not implemented

 

Should this have worked?  Any advice on how to fix this?


Thanks.

 

Roger Spellman

Sr. Staff Engineer

Terascala, Inc.

508-588-1501

www.terascala.com http://www.terascala.com/

 


_______________________________________________
HPDD-discuss mailing list
HPDD-discuss@lists.01.org
https://lists.01.org/mailman/listinfo/hpdd-discuss



_______________________________________________
HPDD-discuss mailing list
HPDD-discuss@lists.01.org
https://lists.01.org/mailman/listinfo/hpdd-discuss